Resolved
The issue has been resolved, and all affected services are now functioning normally.
Thank you for your patience while we worked to address the issue.
Monitoring
We experienced a brief platform issue resulting in temporary delays in email transactional processing. The issue has been resolved, and system performance has returned to normal.
Some emails may have been delayed by a few minutes during this period. At this time, we do not expect any email loss.
We apologize for any inconvenience caused and appreciate your understanding.