Increase in errors
Resolved·Degraded performance

We observed an increase in errors across multiple applications starting at 01:00 AM UTC, which was resolved by 04:00 AM UTC. The issue primarily impacted email and SMS sending (both campaigns and transactional), automation execution, event processing, APIs, and webhooks. Clients may have also experienced intermittent errors while navigating various services on our platform. The root cause was traced to a network component, which has since been fixed. All services have returned to normal, and no further issues are expected. Thank you for your patience.

Fri, May 2, 2025, 04:15 AM
(2 days ago)
·
Affected components
API
Outbound Emails Delivery
Outbound SMS Delivery
Outbound Webhooks Processing
Marketing automation
Updates

Resolved

We observed an increase in errors across multiple applications starting at 01:00 AM UTC, which was resolved by 04:00 AM UTC. The issue primarily impacted email and SMS sending (both campaigns and transactional), automation execution, event processing, APIs, and webhooks. Clients may have also experienced intermittent errors while navigating various services on our platform. The root cause was traced to a network component, which has since been fixed. All services have returned to normal, and no further issues are expected. Thank you for your patience.

Fri, May 2, 2025, 04:15 AM

Monitoring

We have mitigated the impact and are seeing a reduction in errors across the affected services. We continue to monitor our systems closely to ensure stability. We’ll provide an update once we confirm the issue is fully resolved.

Fri, May 2, 2025, 04:01 AM(13 minutes earlier)

Identified

We are continuing to work on mitigating the issue and reducing the impact on the affected services. Our team is actively implementing measures to restore full functionality. We appreciate your patience and will share further updates as progress is made.

Fri, May 2, 2025, 03:02 AM(59 minutes earlier)

Identified

We’ve identified a potential issue with one of our network components and are actively working on mitigation. Upon further investigation, we’ve also found that this is impacting our Events Service as well, resulting in delays in processing events related to transactional and marketing sending, contact updates, and other event-driven actions. Our team is working to resolve the issue as quickly as possible. We’ll continue to provide updates as we make progress.

Fri, May 2, 2025, 02:34 AM(27 minutes earlier)

Investigating

We’ve detected an issue affecting email/sms sending both campaigns and transaction. We also suspect an impact on automation execution and webhook, as a result, some cutomers may be experiencing disruptions while using these applications.

Our team is actively investigating the root cause and working to resolve the issue as quickly as possible. We apologize for the inconvenience and will share further updates as soon as we have more information.

Fri, May 2, 2025, 02:07 AM(27 minutes earlier)
Powered by