Delayed Batch Sending
Resolved·Degraded performance

The issue has been resolved, and all affected services are now functioning normally. Thank you for your patience while we worked to address the issue.

Tue, May 13, 2025, 01:09 PM
(2 days ago)
·
Affected components
Outbound Emails Delivery
Updates

Resolved

The issue has been resolved, and all affected services are now functioning normally. Thank you for your patience while we worked to address the issue.

Tue, May 13, 2025, 01:09 PM

Monitoring

The impact has been mitigated, and the backlog has been successfully processed. Batch sending should now be functioning normally. We are continuing to monitor the service to ensure ongoing stability.

Tue, May 13, 2025, 01:03 PM

Identified

Our team is actively continuing to work on mitigating the impact. We’ll share further updates as soon as we have more information

Tue, May 13, 2025, 12:37 PM(26 minutes earlier)

Identified

We have identified an issue affecting our batch email sending functionality, resulting in delay of approximately one hour for some clients. This issue is limited to batch transactional emails and does not impact other types of transactional email sending. Our team is actively working to resolve the issue and minimize any disruption

Tue, May 13, 2025, 12:03 PM(33 minutes earlier)
Powered by