Events Data Issue
Resolved·Degraded performance

The issue has been resolved, and all affected services are now functioning normally. Thank you for your patience while we worked to address the issue.

Fri, May 16, 2025, 08:41 AM
(1 month ago)
·
Affected components
API
Marketing Email Campaigns
Redirection Links
Inbound Events Tracking
Outbound Webhooks Processing
Marketing automation
Updates

Resolved

The issue has been resolved, and all affected services are now functioning normally. Thank you for your patience while we worked to address the issue.

Fri, May 16, 2025, 08:41 AM

Monitoring

We have mitigated the impact and are seeing a reduction in errors across the affected services. We continue to monitor our systems closely to ensure stability. We’ll provide an update once we confirm the issue is fully resolved.

Fri, May 16, 2025, 08:13 AM(27 minutes earlier)

Identified

We’ve isolated the issue and successfully restored most of the affected services. Event backlog processing has also resumed on our end. Our team is continuing to work on fully restoring the remaining impacted services and is actively monitoring for any ongoing errors.

Fri, May 16, 2025, 07:26 AM(46 minutes earlier)

Identified

Functionalities such as segmentation, redirection, and campaign sending have stabilized and are now operating as expected. We are continuing work to fully restore the remaining affected services, including reporting, event-based webhooks, automation workflows, and API access to email statistics. Thank you for your patience and understanding as we work toward complete resolution.

Fri, May 16, 2025, 06:37 AM(49 minutes earlier)

Identified

We’ve observed a reduction in errors for parts of the system that have been partially restored. Our team remains actively engaged in fully restoring all affected services. We appreciate your patience and will continue to provide updates as progress is made.

Fri, May 16, 2025, 05:46 AM(51 minutes earlier)

Identified

Our team is continuing to work on resolving the ongoing issue affecting our event data systems. Since our last update, we have identified additional impacted services:

  • API requests for retrieving statistics related to transactional and marketing emails

  • Segmentation features that rely on event-based data

  • Redirection services (intermittent errors observed).

  • Sending of marketing campaigns (intermittent errors observed)

We are actively working to restore all affected services to their normal state and will provide further updates as progress is made. We appreciate your patience and understanding.

Fri, May 16, 2025, 04:26 AM(1 hour earlier)

Identified

We are continuing to work on restoring the affected service. Please note that campaign and transactional email sending services are functioning as expected. The impact is currently limited to statistics and event-related functionalities. We appreciate your patience and will share further updates as progress is made.

Fri, May 16, 2025, 02:06 AM(2 hours earlier)

Identified

Our team is still actively working to resolve the ongoing issue. We’re continuing to investigate and apply fixes to restore full functionality. We appreciate your patience and will share further updates as progress is made.

Fri, May 16, 2025, 12:42 AM(1 hour earlier)

Identified

We have identified the cause of the issue affecting Events service. Our team is working on implementing a fix to mitigate the impact. We will continue to share updates as we progress toward resolution.

Thu, May 15, 2025, 11:33 PM(1 hour earlier)

Investigating

We are currently experiencing an issue with our Events service, which is causing statistics for both marketing and transactional emails to display incorrectly. Additionally, webhooks and automations dependent on these events may also be impacted. Our team is actively investigating the root cause and working to resolve the issue as quickly as possible. We apologize for the inconvenience and will share further updates as soon as we have more information.

Thu, May 15, 2025, 10:51 PM(41 minutes earlier)
Powered by