Delay in Transactional Email Delivery
Resolved·Degraded performance

The issue has been resolved. All previously delayed transactional emails have been successfully processed, and the system is now functioning normally. Thank you for your patience while we worked to address the issue.

Tue, May 20, 2025, 03:26 PM
(3 weeks ago)
·
Affected components
Outbound Emails Delivery
Updates

Resolved

The issue has been resolved. All previously delayed transactional emails have been successfully processed, and the system is now functioning normally. Thank you for your patience while we worked to address the issue.

Tue, May 20, 2025, 03:26 PM

Monitoring

A fix has been applied and we are seeing an improvement in processing of transactional emails, however, the delay affecting older emails will also extend to new incoming emails until the backlog is cleared. We are monitoring it.

Tue, May 20, 2025, 03:07 PM(18 minutes earlier)

Identified

We have identified the cause of the issue affecting our transactional email delivery service. Our team is actively implementing a fix to mitigate the impact. We will continue to provide updates as we work toward full resolution.

Tue, May 20, 2025, 02:46 PM(21 minutes earlier)

Investigating

We are currently experiencing delays in the delivery of transactional emails. Our team is actively investigating the root cause and working to resolve the issue as quickly as possible. We apologize for the inconvenience and will share further updates as soon as we have more information.

Tue, May 20, 2025, 02:40 PM
Powered by