Multiple Services Impacted
Resolved·Degraded performance

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Thu, Jun 19, 2025, 04:57 PM
(2 days ago)
·
Affected components
Outbound Emails Delivery
Outbound Webhooks Processing
Marketing automation
Updates

Resolved

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Thu, Jun 19, 2025, 04:57 PM

Monitoring

Automation execution and transactional email preview visibility are now working as expected. All services are functioning normally. We are continuing to monitor and validate overall system stability.

Thu, Jun 19, 2025, 04:52 PM

Monitoring

Webhooks are processing successfully. However, a few users may experience issues with the visibility of transactional email previews. We are continuing to monitor and validate the stability of other affected services.

Thu, Jun 19, 2025, 04:21 PM(30 minutes earlier)

Monitoring

We’ve seen improvements in webhook processing. We are continuing to monitor and validate the stability of other affected services.

Thu, Jun 19, 2025, 03:54 PM(27 minutes earlier)

Monitoring

Transactional email delivery has returned to normal. We are continuing to monitor and validate the stability of other affected services.

Thu, Jun 19, 2025, 02:55 PM(58 minutes earlier)

Identified

The issue was identified with our network backbone, which has since been mitigated. We are currently validating the stability of all impacted services and working to restore full functionality.

Thu, Jun 19, 2025, 02:41 PM(13 minutes earlier)

Identified

We're observing errors across multiple services. Our team has identified the issue as related to one of our network resources and is actively working to resolve it.

Thu, Jun 19, 2025, 02:10 PM(31 minutes earlier)

Identified

We have identified the cause of the issue affecting multiple services. Our team is working on implementing a fix to mitigate the impact. We will continue to share updates as we progress toward resolution.

Thu, Jun 19, 2025, 01:32 PM(37 minutes earlier)

Investigating

We’ve identified an issue impacting Email Delivery, Automation Execution, and the Webhook Service. As a result, some customers may be experiencing disruptions in these functionalities. Our engineering team is actively investigating the root cause and working to restore full service as quickly as possible. We sincerely apologize for the inconvenience and will provide updates as soon as more information becomes available.

Thu, Jun 19, 2025, 01:14 PM(17 minutes earlier)
Powered by