Campaign Sending Delayed
Affected components
Outbound Emails Delivery
Updates

Write-up published

Read it here

Resolved

The issue has been resolved, and campaign sending service is now functioning normally. Thank you for your patience while we worked to address the issue.

Tue, Jun 24, 2025, 10:52 AM

Investigating

We’ve identified an issue in our campaign sending service that is causing delays in the delivery of Email campaigns. The error spike was first observed at 10:00 AM UTC, and all campaigns scheduled after that time are currently affected. Our team is actively investigating the root cause and working on a fix to restore normal operations as soon as possible.

Tue, Jun 24, 2025, 10:40 AM(11 minutes earlier)
Powered by