Delay in outbound email delivery
Affected components
Outbound Emails Delivery
Updates

Write-up published

Read it here

Resolved

The issue has been resolved, and all affected services are now functioning normally. Thank you for your patience while we worked to address the issue.

Thu, Jul 17, 2025, 09:19 PM

Monitoring

A fix has been implemented, and the issue is now resolved. However, delays from the previously queued emails are still impacting new incoming emails. As the backlog is being processed, some emails may experience delays of up to approximately 3 hours (maximum time-frame). We are actively monitoring the situation.

Thu, Jul 17, 2025, 09:02 PM(16 minutes earlier)

Identified

Our team is still actively working on service restoration. While there are no new updates at this time, we remain focused on resolving the issue. We will share the next update within 30 minutes or as soon as new information becomes available. Thank you for your continued patience.

Thu, Jul 17, 2025, 08:26 PM(35 minutes earlier)

Identified

We are continuing to work on restoring full service. While there are no new updates at this time, our team remains focused on the resolution. We will share the next update within 30 minutes or as soon as more information becomes available. Thank you for your continued patience.

Thu, Jul 17, 2025, 07:56 PM(30 minutes earlier)

Identified

We are still in the process of implementing a fix to fully restore services. While there are no new updates at this time, our team continues to work on resolving the issue. We will share the next update within 30 minutes or as soon as more information becomes available. Thank you for your patience.

Thu, Jul 17, 2025, 07:25 PM(30 minutes earlier)

Identified

Our team is actively working on implementing a fix to fully restore the impacted service. While there are no new updates at this moment, we’re continuing to make progress. We’ll share another update within 30 minutes or as soon as more information becomes available. Thank you for your continued patience.

Thu, Jul 17, 2025, 06:54 PM(31 minutes earlier)

Identified

We have identified the cause of the issue affecting outbound email delivery services. Our team is working on implementing a fix to mitigate the impact. We will continue to share updates as we progress toward resolution.

Thu, Jul 17, 2025, 06:23 PM(31 minutes earlier)

Investigating

Our team is still investigating the root cause and working to resolve the issue as quickly as possible. We will share further updates as soon as we have more information.

Thu, Jul 17, 2025, 05:53 PM(30 minutes earlier)

Investigating

We are currently experiencing delays in the delivery of outbound transactional and marketing emails. Our team is actively investigating the root cause and working to resolve the issue as quickly as possible. We apologize for the inconvenience and will share further updates as soon as we have more information.

Thu, Jul 17, 2025, 05:20 PM(32 minutes earlier)
Powered by