Multiple Services Impacted
Affected components
API
SMTP
Outbound Emails Delivery
Outbound SMS Delivery
Marketing Email Campaigns
Redirection Links
Inbound Events Tracking
Outbound Webhooks Processing
Marketing automation
WhatsApp Campaigns
WhatsApp Transactional
Updates

Write-up published

Read it here

Resolved

The issue was identified with one of our network component. It has been resolved, and all affected services are now functioning normally. Thank you for your patience while we worked to address the issue.

Tue, Jul 29, 2025, 08:41 AM

Monitoring

We have mitigated the impact and are seeing a reduction in errors across the affected services. We continue to monitor our systems closely to ensure stability.

We’ll provide an update once we confirm the issue is fully resolved.

Tue, Jul 29, 2025, 08:32 AM

Identified

The following services seems to be impacted:

  • Marketing SMS Sending

  • Transactional SMS

  • Transactional WhatsApp Sending

  • Web Push Campaigns

  • Redirection Links

  • Tracker Services

Some of these services are already beginning to recover, but the issue is still ongoing. There may also be additional services affected as we continue our investigation and working toward mitigating the impact. We sincerely apologize for the inconvenience and will continue to share updates as more information becomes available.

Tue, Jul 29, 2025, 08:24 AM

Investigating

We’ve identified an issue currently affecting multiple services on our platform. Our team is actively investigating the root cause and working to determine the full scope of the impact. We’re treating this issue with high priority and are working to resolve it as quickly as possible. We apologize for the inconvenience and will share further updates as soon as more information becomes available.

Tue, Jul 29, 2025, 08:15 AM
Powered by