All services are fully operational, and newly sent emails are delivering successfully. We have successfully processed the majority of affected emails in our system and they have been delivered as expected. However, some emails sent around 4:45 UTC may still not have been delivered. We appreciate your patience as we work to deliver all communications. If you have any urgent concerns or questions, please don't hesitate to contact our support team.
Resolved
All services are fully operational, and newly sent emails are delivering successfully. We have successfully processed the majority of affected emails in our system and they have been delivered as expected. However, some emails sent around 4:45 UTC may still not have been delivered. We appreciate your patience as we work to deliver all communications. If you have any urgent concerns or questions, please don't hesitate to contact our support team.
Monitoring
We are still actively monitoring the situation and are not seeing any issues. We will provide an update once the issue is fully resolved.
Monitoring
Email delivery is fully operational, with no current system impact. We are still in the process of finalizing recovery from the earlier disruption. Thank you for your patience.
Monitoring
Email delivery is fully functional, and there is no current impact on systems. We're still finalizing recovery from the earlier disruption. Thank you for your continued patience.
Monitoring
Email delivery is fully functional, and there is no current impact on systems. We are still working to fully recover from the earlier disruption. Thank you for your patience as we finalize the restoration.
Monitoring
We are actively monitoring the situation and are not seeing any issues with newly sent emails. We will provide an update once the issue is fully resolved.
Monitoring
There is no current impact on email delivery, and all systems are functioning normally. We are still working to fully recover from the earlier disruption. Thank you for your patience as we complete the restoration.
Identified
All services are fully operational, and newly sent emails are delivering successfully. Earlier today, a brief delay affected delivery of transactional and marketing emails within a specific time window. We’re actively processing the remaining messages from that window and monitoring to ensure full recovery. We’ll share another update once the backlog is fully cleared. Thank you for your patience.
Identified
We have identified the cause of the issue affecting our services. Our team is working on implementing a fix to mitigate the impact. We will continue to share updates as we progress toward resolution.
Investigating
We are investigating an issue affecting partial delivery of both transactional and marketing emails for a subset of clients. A limited set of messages are impacted, and our team is working to resolve the situation as quickly as possible. We appreciate your patience and will provide updates as we have more information.