Campaigns processing Delayed in Spam Check Review
Resolved·Degraded performance

The issue has been fixed, and spam check review processing is now functioning as expected. Campaigns are being reviewed successfully, and the majority have already been processed. The remaining campaigns are expected to be processed shortly. Thank you for your patience while we worked to resolve this issue.

Sun, Sep 21, 2025, 05:19 AM
(2 weeks ago)
·
Affected components
Marketing Email Campaigns
Updates

Resolved

The issue has been fixed, and spam check review processing is now functioning as expected. Campaigns are being reviewed successfully, and the majority have already been processed. The remaining campaigns are expected to be processed shortly. Thank you for your patience while we worked to resolve this issue.

Sun, Sep 21, 2025, 05:19 AM

Monitoring

We are continuing to monitor our systems closely to ensure ongoing stability and performance. We will provide a final update once the issue is fully confirmed as resolved. Thank you for your continued patience.

Sun, Sep 21, 2025, 04:44 AM(34 minutes earlier)

Monitoring

A fix has been implemented, and campaigns have started processing as expected. We are currently monitoring the system to ensure stability and full recovery. We will provide a final update once the issue is confirmed to be fully resolved. Thank you for your patience.

Sun, Sep 21, 2025, 04:11 AM(33 minutes earlier)

Identified

We have identified the cause of the issue affecting some services. Our team is working on implementing a fix to mitigate the impact.

We will continue to share updates as we progress toward resolution.

Sun, Sep 21, 2025, 03:59 AM(11 minutes earlier)

Investigating

We are currently investigating an issue affecting a very small subset of campaigns that are getting stuck during the spam check process. Only campaigns undergoing spam check appear to be impacted. Our engineering team is actively working to identify the root cause and implement a fix. We will provide updates as soon as more information becomes available. Thank you for your patience.

Sun, Sep 21, 2025, 03:37 AM(21 minutes earlier)
Powered by