Issue with multiple Applications
Resolved·Degraded performance

All applications have now recovered and are functioning normally, with no errors reported. Thank you for your patience while we worked to address the issue.

Wed, Nov 5, 2025, 12:46 PM
(1 week ago)
·
Affected components
Outbound Emails Delivery
Outbound SMS Delivery
Marketing Email Campaigns
Contact Import Service
Contact Detail Page
Updates

Resolved

All applications have now recovered and are functioning normally, with no errors reported. Thank you for your patience while we worked to address the issue.

Wed, Nov 5, 2025, 12:46 PM

Investigating

We’ve detected an issue affecting Home page, Segmentation, Email sending, Contacts page, and as a result, some customers may be experiencing disruptions while using it. We have already identified the issue and working on the fix. We will update this incident as soon as the issue is solved on their side.

Wed, Nov 5, 2025, 12:37 PM
Powered by