Issue with Landing Page Service
Resolved·Full outage

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Tue, Nov 18, 2025, 03:00 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Tue, Nov 18, 2025, 03:00 PM

Monitoring

We are pleased to report that we have observed a significant improvement in success rates, and all previously impacted services are now operating normally. We are continuing to monitor the stability of the system closely. We will provide our next update within 30 minutes or if any new information arises. Thank you for your continued patience

Tue, Nov 18, 2025, 02:49 PM(10 minutes earlier)

Investigating

We are currently experiencing two distinct issues stemming from a problem with one of our key provider:

  • Landing Page Service Outage: Our Landing Pages are currently inaccessible to all clients.

  • Intermittent SMS Delays: A very limited number of users are experiencing delays with both Transactional (including 2FA/OTP) and Campaign SMS delivery destined for the USA and UK.

Our engineering team has identified the root cause and is working closely with the provider to urgently resolve these issues and restore full service.

Tue, Nov 18, 2025, 02:42 PM
Powered by