Delay in Marketing and Transactional Email Delivery
Resolved·Degraded performance

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Thu, Nov 27, 2025, 01:29 PM
(6 days ago)
·
Affected components
Updates

Resolved

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Thu, Nov 27, 2025, 01:29 PM

Monitoring

We have implemented a fix to address the delay in both marketing and transactional email delivery. System performance has returned to normal, and pending messages are now being processed as expected. We will continue to monitor performance to ensure stability.

Thu, Nov 27, 2025, 01:26 PM

Identified

We have identified the cause of the issue affecting some services. Our team is working on implementing a fix to mitigate the impact.

We will continue to share updates as we progress toward resolution.

Thu, Nov 27, 2025, 01:25 PM

Investigating

We have identified an issue currently impacting our email delivery , resulting in an approximate delay of up to 10 minutes for both marketing and transactional emails. Our engineering team is actively investigating the root cause and working to restore normal delivery times as quickly as possible. We apologize for any inconvenience this may cause and will provide additional updates as soon as more information becomes available. Thank you for your patience and understanding.

Thu, Nov 27, 2025, 01:19 PM
Powered by