Issues with multiple applications
Affected components
Outbound SMS Delivery
Account & Billing
Meetings
Calls
Updates

Write-up published

Read it here

Resolved

The issue has been resolved, and all affected services are now functioning normally.

Thank you for your patience while we worked to address the issue.

Mon, Oct 20, 2025, 01:02 PM

Monitoring

All applications have now recovered and are functioning normally, with no errors reported. We are continuing to monitor all services to ensure ongoing stability.

Mon, Oct 20, 2025, 11:56 AM(1 hour earlier)

Monitoring

Based on the latest AWS incident status update, the issue on their end has been mitigated, and no further impact is expected. We are seeing recovery across all impacted services on our end and continue to monitor our systems closely to ensure stability.

Mon, Oct 20, 2025, 10:49 AM(1 hour earlier)

Identified

Our SMS delivery service is recovering. All impacted SMS messages have been successfully replayed, with no message loss observed due to the incident.

However, we continue to see errors in our Calls application, which remains impacted. We are actively tracking the ongoing incident on the AWS side and continue to monitor our services closely.

Mon, Oct 20, 2025, 10:12 AM(37 minutes earlier)

Identified

We’ve detected an issue affecting Phone service, SMS delivery in US and UK and 2FA in US and UK, and as a result, some customers may be experiencing disruptions while using it.

The issue is linked to one of our phone and SMS provider, impacted by AWS outage.

We will update this incident as soon as the issue is solved on their side.

AWS Incident can be tracked here: https://health.aws.amazon.com/health/status

Mon, Oct 20, 2025, 09:19 AM(52 minutes earlier)
Powered by